The Ford Torino Page Homepage
Forum Home Forum Home > Model Specific Forum > 1972-1976 Ford and Mercury
  New Posts New Posts RSS Feed - 73 Torino 4-door Losing power/stalling at idle
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

73 Torino 4-door Losing power/stalling at idle

 Post Reply Post Reply
Author
Message
Papeandtaper View Drop Down
New Member
New Member


Joined: 06-April-2018
Location: Providence, RI
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Papeandtaper Quote  Post ReplyReply Direct Link To This Post Topic: 73 Torino 4-door Losing power/stalling at idle
    Posted: 06-April-2018 at 7:17AM
Hi All, First post here. I'm glad to have found you all.
I just purchased a 73 Gran Torino 4-door with the original 302 in it. I'm having some issues, which I'll outline here:
- Idles fine on start, but once engine warms up it will die if I take my foot off the accelerator
- Again, on start it is fine, but once it is warm I lose power on acceleration. It feels like the engine is cutting out momentarily and then coming back in
- Even with my foot on the gas, sometimes it will die when I switch from park to drive

My first suspicion was a vacuum leak, which may be the case as many hoses are quite old. I'll be spending the weekend tinkering with the idle to see if that's the problem. I also suspect it could be a needle valve issue.

If anyone has any experience with such symptoms, any help would be very much appreciated!
Many Thanks,
Mat
Back to Top
7T9_Tbird View Drop Down
Senior Member
Senior Member
Avatar

Joined: 04-December-2017
Location: Athens, Alabama
Status: Offline
Points: 278
Post Options Post Options   Thanks (0) Thanks(0)   Quote 7T9_Tbird Quote  Post ReplyReply Direct Link To This Post Posted: 06-April-2018 at 8:36AM
Does your motor still have the thermostatic vacuum switch? if so, check it for cracks.  i had one in a 71 Mustang(my first car). Was just as you described, and I went round and round with it until I did the wd-40 trick and found the barb for the rubber hose was mostly broken.
John
79 Thunderbird Heritage
79 Thunderbird Town Landau
Back to Top
Big Bird View Drop Down
Senior Member
Senior Member
Avatar

Joined: 25-August-2013
Location: New York
Status: Offline
Points: 3315
Post Options Post Options   Thanks (0) Thanks(0)   Quote Big Bird Quote  Post ReplyReply Direct Link To This Post Posted: 06-April-2018 at 1:50PM
Another possibility is points/condenser. A weak condenser will act like/feel like a lack of fuel/vacuum type issue and it frequently gets worse with heat.
The above post should be read in a "Grumpy Old Man" voice.
Almost forgot: "Get off my lawn!!!"
Randy
1979 T-Bird
2006 GMC Sierra
Back to Top
72FordGTS View Drop Down
Admin Group
Admin Group
Avatar

Joined: 06-September-2005
Location: Ontario, Canada
Status: Online
Points: 2486
Post Options Post Options   Thanks (0) Thanks(0)   Quote 72FordGTS Quote  Post ReplyReply Direct Link To This Post Posted: 06-April-2018 at 2:28PM
What's the idle speed set at when it's warm?  What are you running for ignition?  What carb, I am assuming stock?  Have you checked the if the carb accelerator pump is shooting fuel?
Vince

1972 Ford GTS Sportsroof - Survivor, One Family car
Back to Top
Papeandtaper View Drop Down
New Member
New Member


Joined: 06-April-2018
Location: Providence, RI
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Papeandtaper Quote  Post ReplyReply Direct Link To This Post Posted: 07-April-2018 at 11:03AM
You seem to have found the issue! I had a couple barbs that were cracked. Installed all new hoses today and it’s running great. Thanks everyone!
Back to Top
lynchster View Drop Down
Senior Member
Senior Member
Avatar

Joined: 07-January-2006
Location: Pennsylvania
Status: Offline
Points: 1734
Post Options Post Options   Thanks (0) Thanks(0)   Quote lynchster Quote  Post ReplyReply Direct Link To This Post Posted: 07-April-2018 at 12:04PM
Chuck
72 Gran Torino Sport
91 F-150
Back to Top
7T9_Tbird View Drop Down
Senior Member
Senior Member
Avatar

Joined: 04-December-2017
Location: Athens, Alabama
Status: Offline
Points: 278
Post Options Post Options   Thanks (0) Thanks(0)   Quote 7T9_Tbird Quote  Post ReplyReply Direct Link To This Post Posted: 07-April-2018 at 2:50PM
Thumbs UpBig smile
John
79 Thunderbird Heritage
79 Thunderbird Town Landau
Back to Top
californiajohnny View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05-October-2013
Location: winlock, wa
Status: Offline
Points: 9277
Post Options Post Options   Thanks (0) Thanks(0)   Quote californiajohnny Quote  Post ReplyReply Direct Link To This Post Posted: 07-April-2018 at 4:54PM
Clap
JOHN
74 GRAN TORINO S&H CLONE
74 VETTE CUSTOM
90 S10 BLAZER 4X4 LIFTED
77 CELICA CUSTOM
75 V8 MONZA SUPERCHARGED
79 COURIER VERT. SLAMMED
75 VEGA V6 5 SPD
70 CHEV C10 P/U
68 MUSTANG FB CONVERSION
Back to Top
changinlatitudes View Drop Down
Senior Member
Senior Member
Avatar

Joined: 14-April-2013
Location: Union, MO
Status: Offline
Points: 497
Post Options Post Options   Thanks (0) Thanks(0)   Quote changinlatitudes Quote  Post ReplyReply Direct Link To This Post Posted: 08-April-2018 at 2:48AM
Beer
Matt

1972 Montego MX
2003 Mercury Marauder 300A
1994 F-150 5.8
2016 Ford Fusion Titanium
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.079 seconds.