Print Page | Close Window

302

Printed From: The Ford Torino Page
Category: Engine Specific Forum
Forum Name: Small Block Forum
Forum Description: 221, 255, 260, 302 and 351W engines
URL: http://forum.grantorinosport.org/forum_posts.asp?TID=6689
Printed Date: 20-November-2018 at 4:26PM
Software Version: Web Wiz Forums 11.10 - http://www.webwizforums.com


Topic: 302
Posted By: fordpower
Subject: 302
Date Posted: 06-February-2012 at 11:06AM
working on removing 302 from my pinto.Drained the oil removed the oil filter it had no oil in it.Whats wrong with this pic.It felt heavy like it had oil.



Replies:
Posted By: GTW
Date Posted: 06-February-2012 at 12:04PM
Your pic did not show up

-------------
Griffin
1973 Gran Torino station wagon
1971 Maverick 2 Door
1994 Mark VIII
Retired 60s NHRA Anglia


Posted By: fordpower
Date Posted: 06-February-2012 at 12:54PM
Sorry it was a figure of speech.in other words why no oil in filter


Posted By: ilyes
Date Posted: 06-February-2012 at 1:35PM
because oil drained out to the pan, unless it was running just before you drained it, it's totally ok


Posted By: fordpower
Date Posted: 07-February-2012 at 3:03AM
ok but I have never found one with no sigh of oil in it.


Posted By: ilyes
Date Posted: 07-February-2012 at 12:21PM
I did, depending on oil viscosity, if it does have a no return or not.
If your engine was running dry, you would hear it, trust me


Posted By: fordpower
Date Posted: 08-February-2012 at 9:18AM
Oh it has pressure.Just found it strange none in filter


Posted By: ilyes
Date Posted: 08-February-2012 at 11:37AM
if the paper inside the filter got ripped, that could be a reason


Posted By: fordpower
Date Posted: 09-February-2012 at 3:18AM
once I figure how to get it out I will take it apart.Want to know what cam it has etc.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.10 - http://www.webwizforums.com
Copyright ©2001-2017 Web Wiz Ltd. - https://www.webwiz.net