The Ford Torino Page Homepage
Forum Home Forum Home > Model Specific Forum > Four Doors and Wagons
  New Posts New Posts RSS Feed - Swamp Thang: Electrical issues?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Swamp Thang: Electrical issues?

 Post Reply Post Reply Page  <12
Author
Message
Rockatansky View Drop Down
Senior Member
Senior Member


Joined: 30-July-2010
Location: On The Road
Status: Offline
Points: 4128
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rockatansky Quote  Post ReplyReply Direct Link To This Post Posted: 27-January-2014 at 7:51AM
accessory circuit breaker power feed, I guess it would go through the ignition switch for control?

does yours have a power rear window & does it work with that disconnected?

does it work with the loose wire temp'd to the power terminal?
72 GT Ute
   
Back to Top
Dan the ranchero man View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24-July-2011
Location: Mchenry,IL
Status: Offline
Points: 1075
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan the ranchero man Quote  Post ReplyReply Direct Link To This Post Posted: 27-January-2014 at 1:47PM
yes, that would be for pwr seat opt or rr defroster (ckt breaker)
Back to Top
bmf View Drop Down
Member
Member
Avatar

Joined: 06-February-2011
Location: Chico Ca
Status: Offline
Points: 102
Post Options Post Options   Thanks (0) Thanks(0)   Quote bmf Quote  Post ReplyReply Direct Link To This Post Posted: 29-January-2014 at 3:03PM
In case you have not found it.  There is a wire bundle that runs from the dash, under the seat, and to the rear.  It has connectors and a ground or two.  It is in the channel directly under the seat on the drivers side.
"I am completely broke and have the ability to sustain that"
Back to Top
GranTorinoSport View Drop Down
Admin Group
Admin Group
Avatar
Admin of "The Org"

Joined: 20-May-2003
Location: Seattle
Status: Offline
Points: 2262
Post Options Post Options   Thanks (0) Thanks(0)   Quote GranTorinoSport Quote  Post ReplyReply Direct Link To This Post Posted: 29-January-2014 at 5:22PM
I have that circuit breaker on my 75 Sport, and it has neither rear defrost or power seats?

I am of course removing it as part of the re-engine, but I was trying to figure that one out. I am replacing it all with a heavy duty terminal block and the solenoid is now down on the starter. 

Those wires going from that CB feed the ignition power and others. 
Scott Eklund

Webmaster
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.062 seconds.